# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z])(\1{0,1})\1*/$1$2/ug;t' <<< " Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please.
"