use strict;
my $str = ' Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please.
';
my $regex = qr/([a-z])(\1{0,1})\1*/up;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";