$re = '/([a-z])(\1{0,1})\1*/u';
$str = ' Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please.
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;