const regex = /([a-z])(\1{0,1})\1*/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z])(\\1{0,1})\\1*', 'ug')
const str = ` Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please.
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);