re = /([a-z])(\1{0,1})\1*/
str = ' Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please.
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result