#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)([a-z])(\1{0,1})\1*"
Local $sString = " Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please. " & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)