#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d).*(?=\s*;[s|S]erial)"
Local $sString = "$TTL 10800" & @CRLF & _
"@ IN SOA foreman.quicksand.identix.com. root.quicksand.identix.com. (" & @CRLF & _
" 1 ;Serial" & @CRLF & _
" 86400 ;Refresh" & @CRLF & _
" 3600 ;Retry" & @CRLF & _
" 604800 ;Expire" & @CRLF & _
" 3600 ;Negative caching TTL" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"@ IN NS foreman.quicksand.identix.com." & @CRLF & _
"" & @CRLF & _
"foreman.quicksand.identix.com. IN A 10.32.111.100" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)