import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d).*(?=\\s*;[s|S]erial)";
final String string = "$TTL 10800\n"
+ "@ IN SOA foreman.quicksand.identix.com. root.quicksand.identix.com. (\n"
+ " 1 ;Serial\n"
+ " 86400 ;Refresh\n"
+ " 3600 ;Retry\n"
+ " 604800 ;Expire\n"
+ " 3600 ;Negative caching TTL\n"
+ ")\n\n"
+ "@ IN NS foreman.quicksand.identix.com.\n\n"
+ "foreman.quicksand.identix.com. IN A 10.32.111.100\n\n";
final String subst = "$1\\t";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}