const regex = /(\d).*(?=\s*;[s|S]erial)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d).*(?=\\s*;[s|S]erial)', '')
const str = `\$TTL 10800
@ IN SOA foreman.quicksand.identix.com. root.quicksand.identix.com. (
1 ;Serial
86400 ;Refresh
3600 ;Retry
604800 ;Expire
3600 ;Negative caching TTL
)
@ IN NS foreman.quicksand.identix.com.
foreman.quicksand.identix.com. IN A 10.32.111.100
`;
const subst = `$1\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);