using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d).*(?=\s*;[s|S]erial)";
string substitution = @"$1\t";
string input = @"$TTL 10800
@ IN SOA foreman.quicksand.identix.com. root.quicksand.identix.com. (
1 ;Serial
86400 ;Refresh
3600 ;Retry
604800 ;Expire
3600 ;Negative caching TTL
)
@ IN NS foreman.quicksand.identix.com.
foreman.quicksand.identix.com. IN A 10.32.111.100
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}