import Foundation
let pattern = #"(\d).*(?=\s*;[s|S]erial)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$TTL 10800
@ IN SOA foreman.quicksand.identix.com. root.quicksand.identix.com. (
1 ;Serial
86400 ;Refresh
3600 ;Retry
604800 ;Expire
3600 ;Negative caching TTL
)
@ IN NS foreman.quicksand.identix.com.
foreman.quicksand.identix.com. IN A 10.32.111.100
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\t"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}