#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([1-9]\d{3,}|9[6-9]\d|95[5-9])"
Local $sString = "0001" & @CRLF & _
"12" & @CRLF & _
"953" & @CRLF & _
"954" & @CRLF & _
"955" & @CRLF & _
"956" & @CRLF & _
"1234" & @CRLF & _
"99999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")