using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([1-9]\d{3,}|9[6-9]\d|95[5-9])";
string input = @"0001
12
953
954
955
956
1234
99999";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}