import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1-9]\\d{3,}|9[6-9]\\d|95[5-9])";
final String string = "0001\n"
+ "12\n"
+ "953\n"
+ "954\n"
+ "955\n"
+ "956\n"
+ "1234\n"
+ "99999";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}