package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([1-9]\d{3,}|9[6-9]\d|95[5-9])`)
var str = `0001
12
953
954
955
956
1234
99999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}