const regex = /([1-9]\d{3,}|9[6-9]\d|95[5-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1-9]\\d{3,}|9[6-9]\\d|95[5-9])', 'g')
const str = `0001
12
953
954
955
956
1234
99999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}