// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([1-9]\d{3,}|9[6-9]\d|95[5-9])").unwrap();
let string = "0001
12
953
954
955
956
1234
99999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}