$re = '/([1-9]\d{3,}|9[6-9]\d|95[5-9])/';
$str = '0001
12
953
954
955
956
1234
99999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);