#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\b| )([.,:;!]+)(?: |\b)"
Local $sString = "Hi!stack overflow... is a popular website, I visit it every day." & @CRLF & _
"aaa..." & @CRLF & _
"AAA...BBB" & @CRLF & _
"AA .BBB #unlikely to happen but managed anyway" & @CRLF & _
"Test smilyeys :) :D -.- #One is done, Here the D can't be avoided"
Local $sSubst = " \1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)