const regex = /(?:\b| )([.,:;!]+)(?: |\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b| )([.,:;!]+)(?: |\\b)', 'gm')
const str = `Hi!stack overflow... is a popular website, I visit it every day.
aaa...
AAA...BBB
AA .BBB #unlikely to happen but managed anyway
Test smilyeys :) :D -.- #One is done, Here the D can't be avoided`;
const subst = ` \1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);