package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\b| )([.,:;!]+)(?: |\b)`)
var str = `Hi!stack overflow... is a popular website, I visit it every day.
aaa...
AAA...BBB
AA .BBB #unlikely to happen but managed anyway
Test smilyeys :) :D -.- #One is done, Here the D can't be avoided`
var substitution = " \1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}