import Foundation
let pattern = #"(?:\b| )([.,:;!]+)(?: |\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Hi!stack overflow... is a popular website, I visit it every day.
aaa...
AAA...BBB
AA .BBB #unlikely to happen but managed anyway
Test smilyeys :) :D -.- #One is done, Here the D can't be avoided
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)