import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b| )([.,:;!]+)(?: |\\b)";
final String string = "Hi!stack overflow... is a popular website, I visit it every day.\n"
+ "aaa...\n"
+ "AAA...BBB\n"
+ "AA .BBB #unlikely to happen but managed anyway\n"
+ "Test smilyeys :) :D -.- #One is done, Here the D can't be avoided";
final String subst = " \\1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}