# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\b| )([.,:;!]+)(?: |\b)"
test_str = ("Hi!stack overflow... is a popular website, I visit it every day.\n"
"aaa...\n"
"AAA...BBB\n"
"AA .BBB #unlikely to happen but managed anyway\n"
"Test smilyeys :) :D -.- #One is done, Here the D can't be avoided")
subst = " \\1 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.