package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,2}-\d{1,2}-\d{2,4})(([\w\d]+\s?\d{2}\-\d{2}\-\d{4}]?\s\-\s\d{2}\-\d{2}\-\d{4})|([\w]+))(([\d\,]+)|(\s[\d\,]+)|(\-[\d\,]+))`)
var str = `31-12-2019Forfait 01-01-2019 - 31-12-2019-29,00
31-12-2019Forfait 01-01-2019 - 31-12-201950,00
31-12-2019Mercedes-500,00
31-12-2019Client10 700,00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}