re = /^(\d{1,2}-\d{1,2}-\d{2,4})(([\w\d]+\s?\d{2}\-\d{2}\-\d{4}]?\s\-\s\d{2}\-\d{2}\-\d{4})|([\w]+))(([\d\,]+)|(\s[\d\,]+)|(\-[\d\,]+))/m
str = '31-12-2019Forfait 01-01-2019 - 31-12-2019-29,00
31-12-2019Forfait 01-01-2019 - 31-12-201950,00
31-12-2019Mercedes-500,00
31-12-2019Client10 700,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end