// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{1,2}-\d{1,2}-\d{2,4})(([\w\d]+\s?\d{2}\-\d{2}\-\d{4}]?\s\-\s\d{2}\-\d{2}\-\d{4})|([\w]+))(([\d\,]+)|(\s[\d\,]+)|(\-[\d\,]+))").unwrap();
let string = "31-12-2019Forfait 01-01-2019 - 31-12-2019-29,00
31-12-2019Forfait 01-01-2019 - 31-12-201950,00
31-12-2019Mercedes-500,00
31-12-2019Client10 700,00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}