import re
regex = re.compile(r"^(\d{1,2}-\d{1,2}-\d{2,4})(([\w\d]+\s?\d{2}\-\d{2}\-\d{4}]?\s\-\s\d{2}\-\d{2}\-\d{4})|([\w]+))(([\d\,]+)|(\s[\d\,]+)|(\-[\d\,]+))", flags=re.MULTILINE)
test_str = ("31-12-2019Forfait 01-01-2019 - 31-12-2019-29,00\n"
"31-12-2019Forfait 01-01-2019 - 31-12-201950,00\n"
"31-12-2019Mercedes-500,00\n"
"31-12-2019Client10 700,00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")