const regex = /^(\d{1,2}-\d{1,2}-\d{2,4})(([\w\d]+\s?\d{2}\-\d{2}\-\d{4}]?\s\-\s\d{2}\-\d{2}\-\d{4})|([\w]+))(([\d\,]+)|(\s[\d\,]+)|(\-[\d\,]+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{1,2}-\\d{1,2}-\\d{2,4})(([\\w\\d]+\\s?\\d{2}\\-\\d{2}\\-\\d{4}]?\\s\\-\\s\\d{2}\\-\\d{2}\\-\\d{4})|([\\w]+))(([\\d\\,]+)|(\\s[\\d\\,]+)|(\\-[\\d\\,]+))', 'gm')
const str = `31-12-2019Forfait 01-01-2019 - 31-12-2019-29,00
31-12-2019Forfait 01-01-2019 - 31-12-201950,00
31-12-2019Mercedes-500,00
31-12-2019Client10 700,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}