import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{1,2}-\\d{1,2}-\\d{2,4})(([\\w\\d]+\\s?\\d{2}\\-\\d{2}\\-\\d{4}]?\\s\\-\\s\\d{2}\\-\\d{2}\\-\\d{4})|([\\w]+))(([\\d\\,]+)|(\\s[\\d\\,]+)|(\\-[\\d\\,]+))";
final String string = "31-12-2019Forfait 01-01-2019 - 31-12-2019-29,00\n"
+ "31-12-2019Forfait 01-01-2019 - 31-12-201950,00\n"
+ "31-12-2019Mercedes-500,00\n"
+ "31-12-2019Client10 700,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}