use strict;
my $str = '31-12-2019Forfait 01-01-2019 - 31-12-2019-29,00
31-12-2019Forfait 01-01-2019 - 31-12-201950,00
31-12-2019Mercedes-500,00
31-12-2019Client10 700,00';
my $regex = qr/^(\d{1,2}-\d{1,2}-\d{2,4})(([\w\d]+\s?\d{2}\-\d{2}\-\d{4}]?\s\-\s\d{2}\-\d{2}\-\d{4})|([\w]+))(([\d\,]+)|(\s[\d\,]+)|(\-[\d\,]+))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}