#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^((?:[^|]*\|){3})[^|]+"
Local $sString = "1.1|ProvCM|111111111111|10.15.194.25|10.100.10.3|10.100.10.1|docsis3.0"
Local $sSubst = "$1<mytext>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)