$re = '/^((?:[^|]*\|){3})[^|]+/';
$str = '1.1|ProvCM|111111111111|10.15.194.25|10.100.10.3|10.100.10.1|docsis3.0';
$subst = "$1<mytext>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;