import Foundation
let pattern = #"^((?:[^|]*\|){3})[^|]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1.1|ProvCM|111111111111|10.15.194.25|10.100.10.3|10.100.10.1|docsis3.0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<mytext>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)