package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:[^|]*\|){3})[^|]+`)
var str = `1.1|ProvCM|111111111111|10.15.194.25|10.100.10.3|10.100.10.1|docsis3.0`
var substitution = "$1<mytext>"
fmt.Println(re.ReplaceAllString(str, substitution))
}