// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^((?:[^|]*\|){3})[^|]+").unwrap();
let string = "1.1|ProvCM|111111111111|10.15.194.25|10.100.10.3|10.100.10.1|docsis3.0";
let substitution = "$1<mytext>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}