use strict;
my $str = '1.1|ProvCM|111111111111|10.15.194.25|10.100.10.3|10.100.10.1|docsis3.0';
my $regex = qr/^((?:[^|]*\|){3})[^|]+/p;
my $subst = '$1<mytext>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";