const regex = /^((?:[^|]*\|){3})[^|]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:[^|]*\\|){3})[^|]+', 'g')
const str = `1.1|ProvCM|111111111111|10.15.194.25|10.100.10.3|10.100.10.1|docsis3.0`;
const subst = `$1<mytext>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);