#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<prefix>(?:\bu8|\b[LuU])?)(?:"(?P<dbl>[^"\\]*(?:\\.[^"\\]*)*)"|'(?P<sngl>[^'\\]*(?:\\.[^'\\]*)*)')|R"([^"(]*)\((?P<raw>.*?)\)\4""
Local $sString = ""text'\"here"" & @CRLF & _
"L'text\'"here'" & @CRLF & _
"u8"text'\"here"" & @CRLF & _
"u'text\'"here'" & @CRLF & _
"U"text'\"here"" & @CRLF & _
"R"delimiter(text"'"here)delimiter""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")