const regex = new RegExp('(?P<prefix>(?:\\bu8|\\b[LuU])?)(?:"(?P<dbl>[^"\\\\]*(?:\\\\.[^"\\\\]*)*)"|\\'(?P<sngl>[^\\'\\\\]*(?:\\\\.[^\\'\\\\]*)*)\\')|R"([^"(]*)\\((?P<raw>.*?)\\)\\4"', 'g')
const str = `"text'\\"here"
L'text\\'"here'
u8"text'\\"here"
u'text\\'"here'
U"text'\\"here"
R"delimiter(text"'"here)delimiter"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}