using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<prefix>(?:\bu8|\b[LuU])?)(?:""(?P<dbl>[^""\\]*(?:\\.[^""\\]*)*)""|'(?P<sngl>[^'\\]*(?:\\.[^'\\]*)*)')|R""([^""(]*)\((?P<raw>.*?)\)\4""";
string input = @"""text'\""here""
L'text\'""here'
u8""text'\""here""
u'text\'""here'
U""text'\""here""
R""delimiter(text""'""here)delimiter""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}