re = /(?P<prefix>(?:\bu8|\b[LuU])?)(?:"(?P<dbl>[^"\\]*(?:\\.[^"\\]*)*)"|'(?P<sngl>[^'\\]*(?:\\.[^'\\]*)*)')|R"([^"(]*)\((?P<raw>.*?)\)\4"/
str = '"text\'\\"here"
L\'text\\\'"here\'
u8"text\'\\"here"
u\'text\\\'"here\'
U"text\'\\"here"
R"delimiter(text"\'"here)delimiter"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end