import Foundation
let pattern = #"(?P<prefix>(?:\bu8|\b[LuU])?)(?:"(?P<dbl>[^"\\]*(?:\\.[^"\\]*)*)"|'(?P<sngl>[^'\\]*(?:\\.[^'\\]*)*)')|R"([^"(]*)\((?P<raw>.*?)\)\4""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"text'\"here"
L'text\'"here'
u8"text'\"here"
u'text\'"here'
U"text'\"here"
R"delimiter(text"'"here)delimiter"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)