$re = '/(?P<prefix>(?:\bu8|\b[LuU])?)(?:"(?P<dbl>[^"\\\\]*(?:\\\\.[^"\\\\]*)*)"|\'(?P<sngl>[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\')|R"([^"(]*)\((?P<raw>.*?)\)\4"/';
$str = '"text\'\\"here"
L\'text\\\'"here\'
u8"text\'\\"here"
u\'text\\\'"here\'
U"text\'\\"here"
R"delimiter(text"\'"here)delimiter"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);