import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<prefix>(?:\\bu8|\\b[LuU])?)(?:\"(?P<dbl>[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*)\"|'(?P<sngl>[^'\\\\]*(?:\\\\.[^'\\\\]*)*)')|R\"([^\"(]*)\\((?P<raw>.*?)\\)\\4\"";
final String string = "\"text'\\\"here\"\n"
+ "L'text\\'\"here'\n"
+ "u8\"text'\\\"here\"\n"
+ "u'text\\'\"here'\n"
+ "U\"text'\\\"here\"\n"
+ "R\"delimiter(text\"'\"here)delimiter\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}