using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li.*?>\s*(.*?)\s*</li>";
string substitution = @"<div class=""navigation-heading"">\n<span>\n <span>\1</span>\n</span>\n</div>";
string input = @"<li id=""menu-item-98"" class=""navigation-heading menu-item menu-item-type-custom menu-item-object-custom menu-item-98"">
<a href=""#"">Main</a>
</li>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}