import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li.*?>\\s*(.*?)\\s*</li>";
final String string = "<li id=\"menu-item-98\" class=\"navigation-heading menu-item menu-item-type-custom menu-item-object-custom menu-item-98\">\n"
+ " <a href=\"#\">Main</a>\n"
+ "</li>";
final String subst = "<div class=\"navigation-heading\">\\n<span>\\n <span>\\1</span>\\n</span>\\n</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}