$re = '~<li.*?>\s*(.*?)\s*</li>~s';
$str = '<li id="menu-item-98" class="navigation-heading menu-item menu-item-type-custom menu-item-object-custom menu-item-98">
<a href="#">Main</a>
</li>';
$subst = "<div class=\"navigation-heading\">\n<span>\n <span>\1</span>\n</span>\n</div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;