package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<li.*?>\s*(.*?)\s*</li>`)
var str = `<li id="menu-item-98" class="navigation-heading menu-item menu-item-type-custom menu-item-object-custom menu-item-98">
<a href="#">Main</a>
</li>`
var substitution = "<div class="navigation-heading">\n<span>\n <span>\1</span>\n</span>\n</div>"
fmt.Println(re.ReplaceAllString(str, substitution))
}