const regex = new RegExp('<li.*?>\\s*(.*?)\\s*</li>', 'gs')
const str = `<li id="menu-item-98" class="navigation-heading menu-item menu-item-type-custom menu-item-object-custom menu-item-98">
<a href="#">Main</a>
</li>`;
const subst = `<div class="navigation-heading">\n<span>\n <span>\1</span>\n</span>\n</div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);